Advanced Graphical Interface - AGI
Internal PLC (CODESYS V3)

- CODESYS V3 logic running on AGI 300/400 series product
- Support of Modbus/TCP and RTU communication
- Use of remote CANopen optional modules
Table of contents

1. GENERAL INFORMATION .................................................................................................... 3
   WARNINGS, LEGAL INFORMATION AND SAFETY .......................................................... 3
   ABOUT THE APPLICATION NOTES .............................................................................. 4
2. INTERNAL PLC (CODESYS V3) ....................................................................................... 5
3. CONTROL SOLUTIONS WITH AGI 300/400 SERIES AND CODESYS V3 ...................... 6
   SYSTEM CONFIGURATION ............................................................................................. 6
   COMPACT STAND-ALONE CONTROLLER ....................................................................... 6
   CONTROLLER WITH REMOTE I/O ................................................................................. 6
   CONNECTIVITY IN HMI AND CONTROL SYSTEMS ...................................................... 7
   REQUIREMENTS AND LIMITATIONS .............................................................................. 7
4. GETTING STARTED ............................................................................................................ 8
   CODESYS V3 DEVELOPMENT SYSTEM INSTALLATION ............................................... 8
   DEIF CODESYS PACKAGES INSTALLATION ................................................................. 8
   UPDATING OLD CODESYS PACKAGES ....................................................................... 9
   CREATOR RUNTIME INSTALLATION .............................................................................. 10
   ACTIVATION OF CODESYS V3 LICENSE ON THE OPERATOR PANEL ......................... 10
   CREATION OF A NEW CODESYS PLC PROJECT .......................................................... 11
   DOWNLOAD PLC APPLICATION ................................................................................... 11
   UPLOAD PLC APPLICATION ......................................................................................... 13
   SYMBOL FILE CONFIGURATION WITH CODESYS V3 DEVELOPMENT SYSTEM .......... 13
   COMMUNICATION SETUP IN AGI CREATOR 2.0.X.XXX ............................................... 14
   IMPORT SYMBOL FILES INTO AGI CREATOR 2.0.X.XXX ............................................ 15
   COMMUNICATION DIAGNOSTIC ................................................................................... 15
5. MODBUS TCP .................................................................................................................. 16
   MODBUS TCP MASTER CONFIGURATION .................................................................... 17
   ADD AND CONFIGURE REMOTE MODBUS TCP SLAVE DEVICES ............................... 17
   CONFIGURING MODBUS DATA EXCHANGE .................................................................. 18
   MODBUS TCP SLAVE CONFIGURATION ....................................................................... 19
6. MODBUS RTU .................................................................................................................. 21
   MODBUS RTU SERIAL PORT CONFIGURATION ............................................................ 22
   MODBUS RTU MASTER CONFIGURATION ................................................................. 23
   ADD AND CONFIGURE REMOTE MODBUS RTU SLAVE DEVICES .............................. 23
   CONFIGURING MODBUS DATA EXCHANGE ................................................................ 24
   MODBUS RTU SLAVE CONFIGURATION ..................................................................... 26
7. CAN MASTER .................................................................................................................... 27
   CAN BUS NETWORK CONFIGURATION ....................................................................... 28
   CANOPEN MASTER CONFIGURATION ....................................................................... 28
   DIAGNOSTIC MAPPING ............................................................................................... 30
   DEFINITION OF CAN I/O SLAVES IN THE PLC CONFIGURATION ............................... 30
   SETTINGS FOR CAN SLAVES ..................................................................................... 31
8. INTERNAL CONTROLLER HARDWARE .......................................................................... 33
   THE CAN INTERFACE ................................................................................................. 33
   TIMER RESOLUTION ................................................................................................. 34
1. General information

Warnings, legal information and safety

Warnings and notes
Throughout this document, a number of warnings and notes with helpful user information will be presented. To ensure that these are noticed, they will be highlighted as follows in order to separate them from the general text.

Warnings

Warnings indicate a potentially dangerous situation, which could result in death, personal injury or damaged equipment, if certain guidelines are not followed.

Notes
Notes provide general information, which will be helpful for the reader to bear in mind.

Legal information and disclaimer
DEIF takes no responsibility for installation or operation of the unit. If there is any doubt about how to install or operate the unit, the company responsible for the installation or the operation must be contacted.

The unit is not to be opened by unauthorised personnel. If opened anyway, the warranty will be lost.

Disclaimer
DEIF A/S reserves the right to change any of the contents of this document without prior notice.

The English version of this document always contains the most recent and up-to-date information about the product. DEIF does not take responsibility for the accuracy of translations, and translations might not be updated at the same time as the English document. If there is a discrepancy, the English version prevails.

Safety issues
Installation of the unit should only be carried out by authorised personnel who understand the risks involved in working with live electrical equipment.

Electrostatic discharge awareness
Sufficient care must be taken to protect the terminal against static discharges during the installation. Once the unit is installed and connected, these precautions are no longer necessary.
About the application notes

General purpose
This document includes application notes for DEIF’s AGI 300/400 series. It mainly includes general product information, mounting instructions and wiring descriptions.

The general purpose of the application notes is to help the AGI application designer, with the first steps of installing and using the internal PLC (CODESYS V3).

⚠️ Please make sure to also read the Installation Instructions before starting to work with the AGI 300/400. Failure to do this could result in human injury or damage to the equipment.

Intended users
The Application Notes are mainly intended for the AGI application designer.

Contents and overall structure
This document is divided into chapters, and in order to make the structure simple and easy to use, each chapter will begin from the top of a new page.
2. Internal PLC (CODESYS V3)

This manual describes the AGI control system based on the CODESYS V3 PLC software.

The documentation covers installation and setup of:

- CODESYS V3 logic running on AGI 300/400 series product
- Support of Modbus/TCP and RTU communication
- Use of remote CANopen optional modules

For finding relevant CODESYS programming documentation, please refer to the CODESYS web site www.codesys.com and its online help.
3. Control solutions with AGI 300/400 series and CODESYS V3

AGI products can deliver effective HMI and control solutions based on AGI Creator and CODESYS V3.

The AGI 300/400 series HMI products have been designed to include the CODESYS V3 PLC Runtime. The PLC runtime is automatically transferred to the device, by AGI Creator as part of the AGI Creator Runtime, and it is running with the support of the operating system of the device.

CODESYS V3 Development System is required to develop and debug PLC applications and transfer them to the AGI 300/400 series HMI device. The CODESYS V3 Runtime requires a license activation to be used. CODESYS V3 license is activated within AGI Creator and the license code will then univocally be matched with the operator panel.

License activation is required for the operation of CODESYS V3 Runtime. CODESYS V3 Runtime will not communicate with the CODESYS V3 development system until after license activation.

System configuration

The HMI and control solution based on AGI Creator and CODESYS V3 can be applied in different configurations.

Compact stand-alone controller

The HMI and control system can be used to build very compact stand-alone systems. Input/output is available using the optional I/O module.

Controller with remote I/O

A fieldbus interface (either built-in or with an optional module) is available for the HMI and control solution. Configurations with local and distributed I/Os are possible.
Connectivity in HMI and control systems

Even when adding the control option with the CODESYS V3 PLC, the HMI still retains its full communication capabilities based on AGI Creator communication drivers.

The communication capabilities over serial network are limited by the amount of serial interfaces available. Each serial interface supports a single communication protocol. Specific optional add-on serial interface modules are available to increment the amount of serial interfaces at disposal.

Requirements and limitations

The following firmware and software versions are required to work with the CODESYS V3 PLC

<table>
<thead>
<tr>
<th>Element</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>AGI</td>
<td>300 or newer</td>
</tr>
<tr>
<td>BSP</td>
<td>1.76 or higher</td>
</tr>
<tr>
<td>Creator</td>
<td>2.0.0.328 or higher</td>
</tr>
<tr>
<td>CODESYS</td>
<td>3.5.4 or higher</td>
</tr>
</tbody>
</table>
4. Getting started

This chapter provides the necessary information on how to set up the HMI + CODESYS PLC system. The required operations are listed below and will be explained in the following chapters.

- CODESYS V3 development system installation
- DEIF CODESYS package installation
- AGI Creator Runtime installation in the operator panel
- Activation of the CODESYS V3 license into the operator panel
- Creation of a new PLC project
- Download PLC application
- Symbol file configuration with CODESYS V3 development system
- Communication setup in AGI Creator

CODESYS V3 development system installation

The CODESYS V3 development system can be downloaded for free from the CODESYS website at: www.codesys.com/download.html

You need to register before you can download the software.

DEIF CODESYS packages installation

A dedicated DEIF CODESYS package is required to allow the official CODESYS V3 development software to integrate with your control systems based on AGI 300/400 series platform.

The DEIF package is only included in the AGI Creator from version 2.0.0.328 (and later) located in the installation folder and → “\CODESYS\V3\”. The package is also available for download on the DEIF Extranet.

The CODESYS development system includes a tool called “Package Manager” for the installation of the DEIF CODESYS package. The package manager tool can be launched from the CODESYS development system > Tools > Package Manager. This tool can be used both for checking the installed packages and for installing new ones.

To install the DEIF CODESYS package, open the Package Manager and click the “Install” button and browse for the file with *.package extension – confirm by pressing “Open”.

The installation procedure will start automatically. The system will prompt you with a request for either a complete or typical installation - any of these will install all the required files for support of the CODESYS V3 PLC Runtime features.

The package manager dialogue is visible in the following figure, showing the installed packages.
Updating old CODESYS packages

When a new version of the DEIF CODESYS package is available, it can be installed to update the currently installed DEIF CODESYS package to the latest. This package will always include the newest CODESYS V3 PLC Runtime features.

When a new version of DEIF CODESYS package is released, we always aim for complete compatibility with the previous versions.

If the new package is not fully compatible with the previous version, some changes to adapt the PLC application to the new package may be required. In these cases, the updates to the DEIF package will come with proper instructions for the conversion of existing projects.

The package update procedure is identical to the first installation of the CODESYS package, please refer to the proper chapter for specific information.

**CODESYS V3 keeps the older package versions instead of replacing them in order to have all the installed packages at disposal if required.**
Creator Runtime installation
The HMI and control system is composed by two main subsystems - the Creator HMI Runtime and the CODESYS V3 PLC Runtime.

As the CODESYS PLC Runtime is part of the AGI Creator HMI Runtime, it is necessary to install the AGI Creator Runtime on the operator panel in order to have the CODESYS PLC Runtime running. For further information on installing the runtime, please refer to the AGI Creator help file.

Activation of CODESYS V3 license on the operator panel
CODESYS V3 PLC Runtime license is activated on the operator panel through an Ethernet connection using AGI Creator version 2.0.0.328 (or later). Each license can be used on one single operator panel, which means that once it has been activated, the license is univocally matched with the MAC-ID of the operator panel.

To activate the license, follow the below steps:

In AGI Creator select, Run > Manage Target

On the License tab > locate the Panel Info section > select the IP address of the operator panel where the license will be activated, chosen from the drop-down menu. The drop-down menu will be a list of operator panels available on the network.

Locate the Activation Keys section > type in the license provided from DEIF.

Click the Activate Panel button.

Once the system confirms the license to be successfully activated, reboot the operator panel to complete the activation procedure.

The CODESYS V3 license activation procedure requires an active internet connection on the PC.
For testing purposes, it is possible to use a temporary demo license that will activate the CODESYS V3 PLC Runtime for **120 minutes**. To activate the demo mode, enter the license code: **CODESYS_DEMO**. The runtime will end itself after this time and reboot will be needed.

**CODESYS V3 licenses, once activated, cannot be paired with a different device nor be deactivated.**

In case it is necessary to verify whether a license has been activated on an HMI, it is possible to check this in the system log of the operator panel.

From the context menu on the operator panel, select the option “Log at boot” and then reboot the operator panel. At panel restart, the log window will be displayed on screen, if a valid CODESYS V3 license is found from the system, then the string “CODESYS Module: CODESYS V3 license found: CODESYS V3 is running” will be present among the panel boot logging information.

**Creation of a new CODESYS PLC project**

To create a new CODESYS V3 project select File > New Project or click the icon from the upper tools bar. A new project dialogue box will be displayed; select “Standard project”, and then define project name and location. Confirm with “OK” as shown in the following figure.

![New Project Dialogue Box](image)

**Download PLC application**

The selection of the PLC, where to download the project, must be chosen from the device communication settings tab before proceeding with the download operation.

Double-click “Device (AGI 300 or AGI 400)” in the project tree to display the device properties in the work area. Make sure you are located in the “Communication Settings” tab; then click the “Scan Network…“ button.

The Select Device dialogue box will be displayed. This dialogue box lists all the compatible devices available in the network (the operator panels are defined as “AGI 300 or AGI 400”). Select your device - then press “OK”.

In case more operator panels use CODESYS V3 PLC Runtime and are present in the same network, a different string between the square brackets reported after the device name can recognise each panel.
In the next figure, the string is “0003.0003.A0C6”. The last two HEX numbers of the string “C6” correspond to the last byte of the operator panel IP Address. In this case, the corresponding operator panel is the one with IP address xxx.xxx.xxx.198 as C6 HEX corresponds to 198 DEC.

The selected device is then listed in the Communication Settings as shown in the next figure. The device properties are listed on screen. A green dot over the device graphical representation informs that the device is correctly recognised and available in the network.

Communication with the available devices is established through a gateway. A default gateway is available and it is generally not needed to change the standard gateway settings. For more information about the gateway setup, please refer to the CODESYS V3 documentation.
Upload PLC application

Uploading the PLC project is possible only if the project source has been previously downloaded to the PLC. To download the project source while online, select Online > Source download to connected device.

To upload a PLC project from the HMI, select the source upload command from the file menu and select the PLC from the device list as shown in the following figure.

Symbol file configuration with CODESYS V3 development system

The CODESYS V3 development system can create a list of all the variables available in the PLC programme in the form of a file with *.xml extension.

The variables to be included in the generated xml file must be selected. To get access to the project variables list, for the selection, it is necessary to add the symbol configuration to the CODESYS project. This project item is not added by default.

To add the symbol configuration, right-click "Application" from the project tree, then in the context menu select Add Object > Symbol configuration. The symbol configuration voice will be added to the project tree, as shown in the following figure.

By double-clicking the symbol configuration, it will be displayed on page.
The symbol configuration contains a list of all the variables available in the CODESYS project. Single variables or groups of variables can be selected by checking the corresponding voice in the list.

The xml symbol file is generated when the application is downloaded to the PLC or when the Build > Generate Code command is executed. The file created is stored in the application folder.

**Communication setup in AGI Creator 2.0.x.xxx**

AGI Creator communicates with the internal CODESYS V3 PLC Runtime using the CODESYS V3 ETH protocol. Local host 127.0.0.1 should be entered in the IP Address parameter. This identifies the PLC as an internal CODESYS V3 Runtime.

Additional information regarding the CODESYS V3 ETH driver are available in AGI Creator, F1 help > Communication Drivers section.
Import symbol files into AGI Creator 2.0.x.xxx

AGI Creator Tag Editor requires direct import of CODESYS V3 symbol file for defining the tags.

Use the command "Import Tags" in AGI Creator Tag Editor to import the symbols generated by the development system.

Select *.xml as Import Type in the AGI Creator Tag import dialogue box, as shown in the following figure.

![Tag Import Dialogue](image)

CODESYS V3 Development System generates a new version of the *.xml file each time the PLC project is built.

CODESYS V3 ETH communication driver supports automatic symbol file (SDB) upload from the PLC; the HMI can upload the symbol table from the PLC using the communication protocol.

Any change in the tag offset information, due to a new compilation of the PLC program, does not require manual re-importing of the symbol file.

However, the symbol file must be imported again when:

- Tags have been renamed
- Tags have changed data format
- New tags have been added.

Communication diagnostic

The AGI 300/400 series can be configured to report communication diagnostic information - also for the communication with the internal PLC Runtime. To display communication diagnostic information, use the proper System Variables or the System Logger. For further information, please refer to the AGI Creator help file.
5. Modbus TCP

CODESYS V3 PLC Runtime can use the built-in Ethernet interface of the operator panels for the distributed Modbus TCP network. No additional hardware is required.

The system can act as Modbus TCP Master or Slave; both configurations are available at the same time.

To add an Ethernet Modbus TCP interface, two steps are required.

Right-click Device (AGI 300 or AGI 400) in the Project tree and select “Add Device”. The Add Device dialogue box is now displayed. The Ethernet device is located under the Fieldbusses > Ethernet Adapter category. Choose the Ethernet device from the list and click “Add Device” to add it to the current PLC configuration.

Right-click Ethernet (Ethernet) in the project tree and select “Add Device”.

Modbus TCP Master and Slave devices are located under the categories Modbus > Modbus TCP Master/Slave; select the required device from the list and click on “Add Device” to add it to the current PLC configuration.
Modbus TCP master configuration

Modbus TCP master configuration is displayed in the work area by selecting the Modbus TCP Master Configuration tab after a double-click on Ethernet > Modbus TCP Master in the project tree.

Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Response Timeout (ms)</td>
<td>Timeout for Modbus slaves reply, given in milliseconds.</td>
</tr>
<tr>
<td>Socket Timeout (ms)</td>
<td>Timeout for socket reply, given in milliseconds.</td>
</tr>
<tr>
<td>Auto-reconnect</td>
<td>If set auto-confirm error and re-establish TCP connection.</td>
</tr>
</tbody>
</table>

Add and configure remote Modbus TCP slave devices

To add a remote Modbus TCP Slave device, right-click Ethernet > Modbus TCP Master in the project tree and select “Add Device”. The Modbus TCP slave devices are located under the category Modbus > Modbus TCP Slave; choose the device from the list and click “Add Device” to add it to the current PLC configuration.

The remote Modbus TCP slave configuration is displayed in the Work area by selecting the Modbus TCP Slave tab after a double click on Ethernet > Modbus TCP Master > Modbus TCP Slave in the project tree.
Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slave IP Address</td>
<td>IP Address of the Modbus TCP slave device.</td>
</tr>
<tr>
<td>Unit-ID</td>
<td>Modbus Node ID of the Modbus TCP slave device</td>
</tr>
<tr>
<td>Response Timeout (ms)</td>
<td>Timeout for Modbus slaves reply, given in milliseconds.</td>
</tr>
<tr>
<td>Port</td>
<td>TCP port used for the communication with the Modbus TCP slave device.</td>
</tr>
</tbody>
</table>

**Configuring Modbus data exchange**

The Modbus data exchange configuration with the Modbus TCP slave can be done in the work area by selecting the Modbus Slave Channel tab after a double click on Ethernet > Modbus TCP Master > Modbus TCP Slave in the project tree.

The configuration is based on channels. For each channel, you can configure a Modbus command that will be sent to the slave. To add a new channel, click the Add Channel button as shown in the following figure. The ModbusChannel dialogue box will now be displayed.
Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Channel name</td>
</tr>
<tr>
<td>Access Type</td>
<td>Selection of the Modbus command.</td>
</tr>
<tr>
<td>Trigger</td>
<td>Specifies if the command should be cyclic or rising edge. If cyclic is chosen, then the cycle time (ms) must be specified between each command. If rising edge is chosen, then a command is launched on the rising edge event of a bit variable defined in the Modbus TCP slave I/O mapping.</td>
</tr>
<tr>
<td>Comment</td>
<td>User comment if required.</td>
</tr>
<tr>
<td>Offset</td>
<td>The starting Modbus address</td>
</tr>
<tr>
<td>Length</td>
<td>Number of registers to be read/written</td>
</tr>
</tbody>
</table>

The mapping configuration of the Modbus TCP Slave I/O is displayed in the work area by selecting the Modbus TCP slave I/O mapping tab after a double-click on Ethernet > Modbus TCP Master > Modbus TCP Slave in the project tree. The mapping shows a list of all the Modbus resources read/write in the configured channels. In case the configured channel uses a rising edge triggered command, the trigger bit is listed in the mapping.

![Modbus TCP Slave I/O mapping](image)

**Modbus TCP slave configuration**

Modbus TCP slave configuration is displayed in the work area by selecting the Modbus TCP tab after a double-click on Ethernet > Modbus TCP Slave Device in the project tree.

*When programmed as explained in this chapter, the CODESYS V3 PLC will act as a Modbus TCP slave device. To configure the device for communication with remote Modbus TCP I/O modules, please refer to the chapter about Modbus TCP master configuration.*
Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>If selected, timeout for Modbus Master queries, given in milliseconds.</td>
</tr>
<tr>
<td>Slave port</td>
<td>TCP port used for the communication with the Modbus TCP Slave device</td>
</tr>
<tr>
<td>Unit-ID</td>
<td>Modbus Node ID of the Modbus TCP slave device</td>
</tr>
<tr>
<td>Holding Registers (%IW)</td>
<td>Number of holding registers available in PLC memory</td>
</tr>
<tr>
<td>Input Registers (%QW)</td>
<td>Number of input registers available in PLC memory</td>
</tr>
<tr>
<td>Start address</td>
<td>Starting address for Modbus resources in PLC</td>
</tr>
</tbody>
</table>

The Mapping configuration of the Modbus TCP slave device is displayed in the work area by selecting the Modbus TCP Slave Device I/O Mapping tab after a double-click on Ethernet > Modbus TCP Slave Device in the project tree.
6. Modbus RTU

CODESYS V3 Runtime can use the built-in serial interface of the HMI device for the distributed Modbus RTU network. One single serial interface is available as built-in option for the AGI 300/400 series HMI. With the use of optional plug-in modules, it is possible to have up to three serial interfaces on the device.

The system can act as Modbus RTU master or slave; both configurations are available at the same time.

To add a Modbus RTU interface, two steps are required.

Right-click on Device (AGI 300 or AGI 400) in the project tree and select “Add Device”. The Add Device dialogue box is now displayed. The Modbus COM device is located under the Fieldbusses > Modbus > Modbus Serial port category, choose the Modbus COM device from the list and click on “Add Device” to add it to the current PLC configuration.

Right-click on Modbus COM in the project tree and select “Add Device”. Modbus RTU Master and Slave devices are located under the Fieldbusses > Modbus > Modbus Serial Master/Device categories. Choose the required device from the list and click “Add Device” to add it to the current PLC configuration.
Modbus RTU serial port configuration

Modbus RTU serial port configuration is displayed in the work area by selecting the Modbus Serial Port Configuration tab after a double click on Modbus COM in the project tree.

Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COM Port</td>
<td>Serial COM Port number (1-4).</td>
</tr>
<tr>
<td>Baud Rate</td>
<td>Communication Baud Rate.</td>
</tr>
<tr>
<td>Parity</td>
<td>Communication Parity.</td>
</tr>
<tr>
<td>Data Bits</td>
<td>Communication Data Bits.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Communication Stop Bits.</td>
</tr>
</tbody>
</table>

The communication mode for the selected serial port is displayed in the work area by selecting the Interface Parameters tab after a double-click on Device (AGI 300 or AGI 400) in the project tree. The mode of the serial interface parameter is RS-232, RS-485, RS-422.
Modbus RTU master configuration

Modbus RTU master configuration is displayed in the work area by selecting the Modbus Master Configuration tab after a double-click on Modbus COM > Modbus Master COM in the project tree.

Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Response Timeout (ms)</td>
<td>Timeout for Modbus slaves reply, given in milliseconds.</td>
</tr>
<tr>
<td>Time between frames (ms)</td>
<td>Waiting time between slave reply and next master query.</td>
</tr>
<tr>
<td>Auto-restart communication</td>
<td>If set, auto-confirm error and re-establish communication.</td>
</tr>
</tbody>
</table>

Add and configure remote Modbus RTU slave devices

To add a remote Modbus RTU slave device, right click on Modbus COM > Modbus Master COM in the project tree and select “Add Device”. Modbus RTU slave devices are located under the category Fieldbusses > Modbus > Modbus Serial Slave. Choose the device from the list and click “Add Device” to add it to the current PLC configuration.

Remote Modbus RTU slave configuration is displayed in the work area by selecting the Modbus Slave Configuration tab after a double-click on Modbus COM > Modbus Master COM > Modbus Slave COM Port in the project tree.
Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slave Address</td>
<td>Modbus Node ID of the Modbus RTU slave device</td>
</tr>
<tr>
<td>Response Timeout (ms)</td>
<td>Timeout for Modbus slaves’ reply, given in milliseconds.</td>
</tr>
</tbody>
</table>

**Configuring Modbus data exchange**

Modbus data exchange configuration with the Modbus RTU slave can be done in the work area by selecting the Modbus slave channel tab after a double-click on Modbus COM > Modbus Master COM > Modbus Slave COM Port in the project tree.

The configuration is based on channels. For each channel, you can configure a Modbus command that will be sent to the slave. To add a new channel, click the Add Channel button, as shown in the following figure. The ModbusChannel dialogue box will be displayed in the page, allowing you to set up the channel.
Available parameters are:

<table>
<thead>
<tr>
<th><strong>Element</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Channel name</td>
</tr>
<tr>
<td>Access Type</td>
<td>Selection of the Modbus command.</td>
</tr>
<tr>
<td>Trigger</td>
<td>Specifies if the command should be cyclic or rising edge. If cyclic is chosen,</td>
</tr>
<tr>
<td></td>
<td>then the cycle time (ms) must be specified between each command. If rising</td>
</tr>
<tr>
<td></td>
<td>edge is chosen, then a command is launched on the rising edge event of a bit</td>
</tr>
<tr>
<td></td>
<td>variable defined in the Modbus TCP slave I/O mapping.</td>
</tr>
<tr>
<td>Comment</td>
<td>User comment if required</td>
</tr>
<tr>
<td>Offset</td>
<td>The starting Modbus address</td>
</tr>
<tr>
<td>Length</td>
<td>Number of registers to be read/written</td>
</tr>
</tbody>
</table>

Mapping configuration of the Modbus RTU slave is displayed in the work area by selecting the Modbus Generic Serial Slave I/O Mapping tab after a double click on Modbus COM > Modbus Master COM > Modbus Slave COM Port in the project tree. Mapping shows a list of all the Modbus resources read/write in the configured channels. In case the configured channel uses a rising edge triggered command, the trigger bit is listed in the mapping.
Modbus RTU slave configuration

Modbus RTU slave configuration is displayed in the work area by selecting the Modbus Serial Device tab after a double-click on Modbus COM > Modbus Serial Device in the project tree.

When programmed as explained in this chapter, the CODESYS V3 PLC will act as a Modbus RTU slave device. To configure the device for the communication with remote Modbus RTU I/O modules, please refer to the chapter Modbus RTU master configuration.

Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit-ID</td>
<td>Modbus Node ID of the Modbus TCP slave device</td>
</tr>
<tr>
<td>Timeout</td>
<td>If selected, timeout for Modbus Master queries, given in milliseconds</td>
</tr>
<tr>
<td>Holding Registers (%IW)</td>
<td>Number of holding registers available in PLC memory</td>
</tr>
<tr>
<td>Input Registers (%IW)</td>
<td>Number of input registers available in PLC memory</td>
</tr>
</tbody>
</table>

Mapping configuration of the Modbus RTU Slave device is displayed in the work area by selecting the Modbus Serial Device I/O Mapping tab after a double-click on Modbus COM > Modbus Serial Device in the project tree.
7. CAN master

CODESYS V3 Runtime can act as a CAN master to allow the use of distributed CANopen I/O points. To interface the operator panel with CAN network, one of the available CAN optional modules must be installed.

The following figure shows AGI 304 and AGI 307 with the optional CANopen module mounted.

To add a CANopen master interface, two steps are required.

Right-click Device (AGI 300) in the project tree and select “Add Device”. The Add Device dialogue box is now displayed. The CAN bus device is located under the category Fieldbusses > CANbus. Choose the CAN bus device from the list and click “Add Device” to add it to the current PLC configuration.

Right-click CANbus in the project tree and select “Add Device”. The CANopen manager device is located under the category Fieldbusses > CiA CANopen > CiA CANopen Manager. Choose the CANopen Manager device from the list and click “Add Device” to add it to the current PLC configuration.
The parameters of the CAN interface are grouped in three tabs accessible on the right part of the PLC configuration tool when the CAN master element has been added to the configuration tree.

A complete and detailed description of the configuration of CAN controllers and the configuration of CAN slave devices is included in the CODESYS user manual.

**CAN bus network configuration**

The CAN bus configuration is displayed in the work area by selecting the CANbus tab after a double-click on CANbus in the project tree.

All operator panel models of type AGI 315x (1GHz ARM CPU) can support two CAN networks.

Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>CAN network number 0 is default, in case double CAN network configuration Network 1 is used for the second CAN network.</td>
</tr>
<tr>
<td>Baud rate (bit/s)</td>
<td>CAN network Baud rate.</td>
</tr>
</tbody>
</table>

**CANopen master configuration**

The CANopen master configuration is displayed in the work area by selecting the CANopen Manager tab after a double-click on CANbus > CANopen Manager in the project tree.
Available parameters are:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node ID</td>
<td>CAN node number assigned to the CAN master.</td>
</tr>
<tr>
<td>Autostart CANopen manager</td>
<td>If selected, the CANopen manager starts automatically if all mandatory slaves are ready. If not selected, the manager must be started by the application, using the CiA405 NMT function block for this purpose.</td>
</tr>
<tr>
<td>Polling of optional slaves</td>
<td>If an optional slave does not respond during start-up sequence, the system polls the slave every second until the slave responds successfully.</td>
</tr>
<tr>
<td>Start slaves</td>
<td>If selected, the CAN master starts the slaves automatically. Otherwise, the start operation must be done in the application.</td>
</tr>
<tr>
<td>NMT Start All</td>
<td>If the start slaves option is selected, it is possible to enable NMT Start All function. This function will start all the slaves at the same time when all the slaves are ready. If not enabled, each slave is started separately.</td>
</tr>
<tr>
<td>NMT error behaviour</td>
<td>This option allows you to determine the behaviour on a guard event; the available options are Restart Slave or Stop Slave.</td>
</tr>
<tr>
<td>Enable sync producing</td>
<td>Enable the sending of sync telegrams on the CAN bus.</td>
</tr>
<tr>
<td>COB-ID (Hex)</td>
<td>COB-ID of the sync message, standard ID is 128 (80 Hex).</td>
</tr>
<tr>
<td>Cycle Period (µs)</td>
<td>Time interval between two sync messages, given in microseconds.</td>
</tr>
<tr>
<td>Window length (µs)</td>
<td>Length of the time window for synchronous PDOs, given in microseconds.</td>
</tr>
<tr>
<td>Enable sync consuming</td>
<td>If selected, the sync messages are supposed to be produced by a different device on the CAN network; the CANopen manager will receive such messages.</td>
</tr>
<tr>
<td>Enable heartbeat producing</td>
<td>If selected, the master sends heartbeat messages on the CAN network.</td>
</tr>
<tr>
<td>Node ID</td>
<td>CAN identifier of the heartbeat messages producer (1-127).</td>
</tr>
<tr>
<td>Producer time (ms)</td>
<td>Time interval between two heartbeat messages, given in milliseconds.</td>
</tr>
<tr>
<td>Enable TIME producing</td>
<td>If selected, the master sends TIME messages on the CAN network.</td>
</tr>
<tr>
<td>COB-ID (Hex)</td>
<td>COB-ID of the TIME messages, default value is 256 (100 Hex).</td>
</tr>
<tr>
<td>Producer time (ms)</td>
<td>Time between two time messages, given in milliseconds. Must be a multiple of the task cycle time.</td>
</tr>
</tbody>
</table>
Diagnostic mapping
When a CAN master device is added to the PLC configuration, the system automatically creates a variable of the type CANOpenManager in the project. This variable contains the diagnostic information about the CAN master.

The variable name is assigned by default but can be changed by changing the I/O module name in the PLC configuration. The variable is reported in the CANopen I/O mapping tab, displayed in the work area by double-clicking the CANbus > CANopen Manager in the project tree, as shown in the following figure.

Definition of CAN I/O slaves in the PLC configuration
After the setup of the CAN master, the structure of available CAN I/O slaves can be defined.

To add a CANopen I/O slave, right-click CANopen Manager in the Project tree and select “Add Device”. The Add Device dialogue box is now displayed. The list of available CANopen I/O slaves is located under the Fieldbusses > CiA CANopen > CiA Remote Device category. Choose the device from the list and click “Add Device” to add it to the current PLC configuration.

Installation of third part CAN slaves in CODESYS V3 requires a specific EDS descriptor file, provided by the CAN slave manufacturer. Please refer to the CODESYS manual for detailed information regarding the installation of the EDS files.
Settings for CAN slaves
The configuration for the CAN slaves has a common part, which is independent of the EDS file. The next figure shows the CANopen Remote Device tab of a CAN slave displayed in the work area, after a double-click on CANbus > CANopen Manager > CAN SLAVE NAME in the project tree. The parameters shown in the figure can be shown by selecting the Enable Expert Settings option.

For specific information regarding the setup of the CAN slaves, please refer to the documentation provided by the CAN slave manufacturer.
Parameters available differ, depending on the chosen slave:

<table>
<thead>
<tr>
<th><strong>Element</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Node ID</td>
<td>CAN node number of the CAN slave device (1 – 127).</td>
</tr>
<tr>
<td>Create all SDOs</td>
<td>When selected, the SDO messages for the slave configuration, depending on the PDO mapping, are created for all objects. When selected, the SDO messages for the slave configuration, depending on the PDO mapping, are created for all objects. When not selected, the SDO messages for the slave configuration are created only for the modified objects. In this latter case, please make sure that the EDS file loaded in CODESYS V3 matches the hardware device features. Otherwise, some required SDO messages will be erroneously skipped.</td>
</tr>
<tr>
<td>Enable sync producing</td>
<td>If selected, this device sends sync messages on the CAN network. This option is selectable only if the sync messages production at the CANopen master side is disabled.</td>
</tr>
<tr>
<td>No initialisation</td>
<td>If selected, the sequence of SDO messages required for the device initialisation (PDO mapping) will not be created.</td>
</tr>
<tr>
<td>Optional device</td>
<td>If selected, the current device is considered as optional in the bus. At start-up, the CAN controller will check if it is at present applying the following rules:</td>
</tr>
<tr>
<td></td>
<td>If the device has been present since start-up and correctly replies to the CANopen mandatory object “Device Type” query (matching the EDS file specification), then it is started. The master will continue with the next device.</td>
</tr>
<tr>
<td></td>
<td>If the device has been present since start-up and it does not reply as expected to the “Device type” query, it is not started. The master then stops, reporting a mismatching error in the CAN configuration; if the “Optional device” with not-matching “Device Type” is inserted in the bus after start-up, the master will skip it and continue to scan the other devices.</td>
</tr>
<tr>
<td></td>
<td>If the device is not present since start-up, it is simply skipped. The master will continue with the next device.</td>
</tr>
</tbody>
</table>
8. Internal controller hardware

This chapter describes some implementation-specific issues in the CODESYS V3 PLC Runtime developed for use with the AGI 300/400 series HMI products.

The CAN interface

The optional CANopen module includes a CAN bus interface implemented according to the CAN protocol specifications 2.0 A.

This CAN controller only supports standard frame format (2.0 A) with bit rates up to 1 Mbit/s.

The following transfer functions have been implemented:

- Transfer rate and timing
- Message framing (Part A)
- Arbitration accordingly to Part A specifications
- Automatic retransmission in case of lost arbitration or error detection
- Acknowledgement
- Message validation
- Error detection and error signalling
- Global identifier masking (for 11-bit and 29-bit long identifiers)
- Interrupt or data polling-driven software supported
- Automatic transfer of data frame (prepared in SDRAM buffer) triggered by one bit setting
- Automatic receipt of data packets with the allowed frame identifier
- 32 separated SDRAM memory buffers for data packets having the node corresponding ID
- Fully implemented CAN error fault confinement
- Automatic detection of bus off state
- Detection of the heavily disturbed CAN bus and warning

Programming the parameter BaudRateKbps at the value 0 enables the use of custom timing.

The resulting Baud rate is calculated using the formula: \( \text{Bit frequency} = \frac{8 \text{ MHz}}{(\text{Prescaler} \times (1 + T_{\text{setup}} + T_{\text{hold}}))} \)

Valid values for parameters are:

- Prescaler: 1 to 64
- \( T_{\text{setup}} \): 1 to 8
- \( T_{\text{hold}} \): 1 to 4

Other two parameters can affect the behaviour of the CAN controller:

- \( \text{SyncJumpWidth} \): defines the number of time quanta (8 MHz/Prescaler) allowed to accept a SYNC pulse. Valid values are 1 to 4.
- \( \text{SampleMode} \): defines the number of times the bit is sampled before it is considered valid. Valid values are 0 (1 sample) and 1 (3 samples).
**Timer resolution**

The resolution of CODESYS V3 timers is 1 millisecond. When a timer value is defined, it is internally translated to the corresponding number of milliseconds.

The resolution of the internal real time clock is 1 millisecond allowing the maximum resolution of timers. Note that the execution time of the PLC programme may apparently affect the resolution of timers.